/halp/ - LynxChan technical assistance

General support

Mode: Thread
Name
Subject
Message

Max message length: 4096

Files

Max file size: 1.00 MB

Max files: 3

Captcha
E-mail
Password

(used to delete files and postings)

Misc

Remember to follow the rules


StephenLynx##xS3ESC 08/11/2015 (Tue) 13:08:59 No. 3 [Reply]
The main IRC channel is #lynxchan at Rizon.
I also created a side-channel with the same name at OFTC for TOR users.
Avoid using the channel at OFTC unless you REALLY can't or don't want to use Rizon to avoid fragmenting information exchange.

(53.53 KB 450x434 garbage.jpg)
Anonymous 05/23/2019 (Thu) 13:07:31 No. 749 [Reply]
I'm still having a problem with thumbnails. If I set the CSS and the global settings for thumbnails to be the same size, it works. Thumbnails show up large. However, in some posts will multiple images, they go outside the frame.
How do I solve this?
6 posts omitted.
>>754
2.2.x doesn't fix the problem either.
>>754
And actually it looks like it got worse. Now thumbnails of really big images shrink when clicked on.
http://libre.land/meta/res/3.html#203
>There are some things set on the cell that holds the image
(296.91 KB 614x665 a.png)
why set thumbnail size with css.. thats very gay. you should instead pass the correct parameters to the thumbnailing program. that way it will always have the correct size instead of the current random size.
>>759
You are getting it wrong. Is not random, there is a set size passed to imagemagick that can be configured. The css is only a complement so pages won't stretch while the thumbs load.

(853.91 KB 600x338 7zip.gif)
Anonymous 05/21/2019 (Tue) 19:46:56 No. 740 [Reply]
Files do not expand when clicked on. How do I fix this?
3 posts omitted.
Also, you should change the css for thumbs to use the same size you have on your back-end settings. I think the css is slightly larger, making thumbs look blurred.
>>744
What CSS file would that setting me in?
>>745
I think it's postings.
>>744
I did this, now multi-file posts overlap. What do?

Favicon Anonymous 04/08/2019 (Mon) 02:51:38 No. 600 [Reply]
Is there a global setting to set a favicon or should I manually edit it in every file?
5 posts omitted.
>>730
>can upload any file to mongo and it will be served as is
i want to use a png but isn't the engine looking for favicon.ico cos i see
> "GET /favicon.ico HTTP/1.1" 404 464
in the error log
>>731
Is not the engine looking for it, is the browser.
>I don't know, that's up to browsers.
>>729
>>731
long story short
> png put png doesn't show
> png put ico does show
> ico put ico does show
mystery solved
>>736
its not going to work if the file is not a .ico. its what the browser always looks for and you get those errors because it cant find a .ico file
>>737
idk tested in ff n chrom, werkd

(35.58 KB 281x284 Look at me I'm human rash.png)
Anonymous 05/12/2019 (Sun) 00:34:35 No. 662 [Reply]
My Lynxchan install doesn't properly render the captcha. It give me this error.

Error: Command failed: convert -size 300x100 xc: -draw "circle 62,36 71,66 circle 232,52 240,56 circle 37,77 48,93 circle 119,40 122,58 circle 53,89 73,109 circle 129,34 143,46 circle 34,72 49,87" -write mpr:mask +delete xc: -pointsize 70 -gravity center -draw "text 0,0 '4c6e41'" -write mpr:original +delete mpr:original -negate -write mpr:negated +delete mpr:negated mpr:original mpr:mask -composite -distort Shepards '0,0 0,0 0,100 0,100 300,0 300,0 300,100 300,100 5,82 9,85 81,36 89,40 175,67 170,90 240,49 220,55' -blur 0x1 jpg:- convert-im6.q16: unable to read font `helvetica' @ error/annotate.c/RenderFreetype/1387. convert-im6.q16: non-conforming drawing primitive definition `text' @ error/draw.c/DrawImage/4216. convert-im6.q16: unable to read font `helvetica' @ error/annotate.c/RenderFreetype/1387. convert-im6.q16: non-conforming drawing primitive definition `text' @ error/draw.c/DrawImage/4216. convert-im6.q16: unable to read font `helvetica' @ error/annotate.c/RenderFreetype/1387. convert-im6.q16: non-conforming drawing primitive definition `text' @ error/draw.c/DrawImage/4216. convert-im6.q16: unable to read font `helvetica' @ error/annotate.c/RenderFreetype/1387. convert-im6.q16: non-conforming drawing primitive definition `text' @ error/draw.c/DrawImage/4216. convert-im6.q16: unable to read font `helvetica' @ error/annotate.c/RenderFreetype/1387. convert-im6.q16: non-conforming drawing primitive definition `text' @ error/draw.c/DrawImage/4216.

What should I do?
What is your distro and imagemagick version installed?
>>663
Ubtuntu 18.10 x64
ImageMagick 6.9.10-8 Q16
>>664
The recommended distro is centos 7 and imagemagick version is 6.7.8-9.

Now, I run lynxchan on ubuntu 18 for development without issues with IM 6.9.7-4 Q16. So I dunno, mayb you did something weird on your install. You are like, the third person having this very same issue, none of them using centos.
werks fine for me™
>: unable to read font `helvetica'
looks like a font error.. do you have it installed

(42.68 KB 640x480 1.jpg)
Anonymous 05/19/2019 (Sun) 15:41:15 No. 733 [Reply]
How do I add more CSS options other than default and clear?
>>>/lynxchan/806
To be more specific.

(163.21 KB 392x324 JJJJJUUUUUUUSSSSSTTTTT.png)
Anonymous 05/18/2019 (Sat) 22:29:20 No. 717 [Reply]
I get a "connection failed" when I try to upload a video on my board. What could be causing this?
4 posts omitted.
>>721
Are you using any webserver between lynxchan and the client? I remember some dude having issues uploading stuff because of his webserver.
>>722
Also, can you show me the page with 400 bad request?
>>723
I'm using nginx as a reverse proxy.
>>723
It was a basic nginx error page, however I thought it might be because the server was timing out before it could properly deliver the reqest. So I went into the nginx.conf and changed the timeout to be much higher. Now it gives a "413 Request Entity Too Large". Googling how to fix it, now that I have a more specific error message.
>>724
Turns out the problem was Nginx not allowing big requests. Fixed it. Thanks for the help.
>>725
np
:v

Anonymous 05/12/2019 (Sun) 14:14:54 No. 666 [Reply]
can you post the css folder currently running on this site?
>>666
See the "lynxhub" branch on penumbra.
https://gitgud.io/LynxChan/PenumbraLynx/tree/lynxhub
(208.63 KB 1357x888 scrot.png)
>>667
Even using this it still loads up the shitty dark theme.
>>715
You fucked up something, bro. Did you use rfe to reload the fe in ram?

(69.07 KB 448x429 1557772871222.jpg)
Anonymous 05/16/2019 (Thu) 07:34:27 No. 708 [Reply]
i tried to edit a post (of mine) but a pop up showed this:
>Internal server error. Posting could not be found.

steps?
>click mod thread
>click Edit on a post
>click Save

v2.1.5
>>708
Was is an op or a reply?
It was bug on penumbra's js. Do a git pull on the front-end and run lynxchan -rfe -nd to refresh the front-end without having to restart the engine. Or restart the engine if you want. I fixed it on the master branch and on the 2.1.x branch.
>>709
reply
>>710
edit box has this >>>/lynxchan/771
>>713
Another penumbralynx bug introduced recently. Fixed on master and 2.1.

Anonymous 05/12/2019 (Sun) 22:22:48 No. 668 [Reply]
Installing LynxChan on CentOS 7 because the captcha never loads on Ubuntu. Attempting to run the lynxchan package gives me pic related.
What should I do?
29 posts and 2 images omitted.
>>702
Thanks, trying this.
>>703
Im pretty sure this is what happened:
You ran the setup script and said y to everything.
The engine and front-end are on 2.1, the latest stable version.
Then you re-installed the front-end but forgot that detail.

I would have picked that up, but the commit message to the latest commit on 2.1 is the same as the master branch because it was a patch to both branches and I didn't ask for the commith hash.
>>702
I think it works because it doesn't show any error messages but I can't say for sure because I'm now dealing with an unrelated-to-lynxchan issue of only being able to see sites through localhost and not through the IP for whatever reason. Thanks a ton for the help.
>>705
Port is closed.
>>706
You were right, forgot iptables was reset when I reinstalled everything. Thank you very much for the help.

Delete
Report

no cookies?